Back to overview
Resolved
Service Outage
Aug 10, 2026 at 3:12am UTC
Affected services
storyboarder.ai
Resolved
Aug 10, 2026 at 3:34am UTC
The issue was caused by an infrastructure problem at our hosting provider. Service has recovered now.
Affected services
Created
Aug 10, 2026 at 3:12am UTC
We're investigating a disruption affecting the landing page.
Affected services