Back to overview
Downtime

Landing Page Downtime

Apr 15, 2026 at 11:03am UTC
Affected services
storyboarder.ai

Resolved
Apr 15, 2026 at 11:10am UTC

The landing page is back online. Migration completed successfully.

Created
Apr 15, 2026 at 11:03am UTC

The landing page is currently unavailable due to a planned infrastructure migration. The app is not affected.