Back to overview
Downtime
App Downtime
May 19, 2026 at 10:37pm UTC
Affected services
app.storyboarder.ai
Resolved
May 20, 2026 at 1:39am UTC
The incident has been resolved. The outage was caused by an upstream issue with our hosting infrastructure provider. Service has been fully restored and no data was lost. Apologies for the disruption.
Affected services
Created
May 19, 2026 at 10:37pm UTC
The app is currently unavailable. We're investigating.
Affected services