Back to overview
Downtime
Temporary Service Disruption
Jun 1, 2026 at 10:37am UTC
Affected services
app.storyboarder.ai
Resolved
Jun 1, 2026 at 10:43am UTC
All services have been fully restored and the application is operating normally.
Affected services
Created
Jun 1, 2026 at 10:37am UTC
We're investigating a brief disruption affecting the application. We've identified the cause and are working on a fix.
Affected services