Back to overview
Downtime
Temporary Service Disruption
Jun 7, 2026 at 2:22am UTC
Affected services
storyboarder.ai
Resolved
Jun 7, 2026 at 2:25am UTC
The issue was caused by an infrastructure problem at our hosting provider. Service has recovered now.
Affected services
Created
Jun 7, 2026 at 2:22am UTC
We're aware that the service is unreachable and are investigating.
Affected services